Problem

A Blueworx Voice Response system is connected to an Avaya switch with the converse feature. The DNIS information is not sent via the incoming address signaling options, and, therefore, cannot be retrieved by the Blueworx Voice Response system variable SV185.


Cause

The Avaya converse feature sends DNIS information as DTMF keys after Blueworx Voice Response answers the call.


Resolving the problem

Modify the state table that is identified by the system parameter: State Table Name for Incoming Calls (default setting is Incoming_Call) to include the GetData action immediately after the AnswerCall action. The KeyBuffer, Minimum, Maximum, and Timeout parameters for the GetData action should be set according to the length of the DNIS digits and the expected time to receive all digits.


If you want to use the received digits to select the application profile, add an AssignData action to set SV22 with the received digits before calling the InvokeStateTable action.