Problem


BVR V6.1 installation (smit) does not recognize a valid DB2 V9.5 installation.


Environment


DB2 V9.5 already installed on the system but is at a level lower than V9.5.0.4.


Resolving the problem

  1. Verify the DB2 level by running the command:
    /usr/local/bin/db2ls
    WVR V6.1 requires a level of V9.5.0.4 or higher.
  2. If DB2 V9.5 is back level, do NOT install another copy of DB2 at a different install directory, instead upgrade the existing instance to DB2 V9.5 Fix Pack 4 or a higher Fix Pack on DB2 V9.5.
  3. Do not remove the DB2 V8 before running the "DTdatabase -m" command to perform the migration. After a successful migration, DB2 V8 can then be removed if required.