Question


How do I use the debugrec voice recording utility?


Cause


Prior to PTF 4.2.0.400, recording voice input and output on specific telephony channels and taking an adapter trace was only possible using the debugmon tool.

The debugrec voice recording tool considerably simplifies what is required to take a diagnostic recording of voice input and output on specific telephony channels or an adapter trace.

debugrec is shipped in BVR 4.2.0.400 as a single executable in the /usr/lpp/dirTalk/devices/dtqa_bin directory.

Answer


debugrec can operate in one of three modes:
  • Continuous recording to a stereo .wav file, with voice input recorded in the right-hand channel and voice output, recorded on the left-hand channel.
  • Continuous recording of voice input and output to separate vrec* files.
  • Circular recording to a 25-second capacity buffers on the adapter.

Syntax: debugrec trunk channel option
where:

trunk
is the Blueworx Voice Response trunk number in the range 1 to 16 (as displayed on the Blueworx Voice Response System Monitor). Mandatory

channel
is the Blueworx Voice Response channel number (as displayed on the Blueworx Voice Response System Monitor). Mandatory

option
can be one of the following optional parameters or omitted (default):

-v
debugmon option 'v' compatibility. Recording is continous (until stopped) to three (DTXA/DTTA) or four (DTNA) files in the /tmp/ directory. File names are of the form vrec*.

-a
debugmon options '8' and '9' compatibility. The recording is done to a 25-second capacity circular buffer on the adapter. Adapter DSP commands and status are also recorded. Files with the name format trace_rec* are created in the /tmp/ directory.


By default (no option), recording is continuous (until stopped) and a stereo 8KHz A-law or µ-law .wav file is created, where the left channel is 'line out' (what Blueworx Voice Response is playing to the line) and the right channel is 'line in' (what Blueworx Voice Response is receiving from the line). The file name used for the recording is /tmp/vrec_line_stereo.wav.

All other parameters required by the tool such as the adapter type and trunk type are obtained automatically from Blueworx Voice Response internal configuration information.

Usage:
For most problems, the default option (stereo .wav file) will be all that is required as it simply records what Blueworx Voice Response is sending to and receiving from the specified telephony channel. In some cases, Blueworx support may request that the -a option is used to record additional internal information which will hopefully allow Blueworx to diagnose the cause of a problem.